You can tell if you are connected to a sensor on the My Instruments page. When your sensor is connected, it will display a small Bluetooth icon in the upper right hand corner. When the sensor is disconnected, the icon will disappear.

To troubleshoot to connection, let's try the following:

  • Confirm that Bluetooth is enabled on your phone or tablet.
  • Is your device within Bluetooth range of the sensor? Depending on the construction of your home, the container you are keeping your sensor in, and other various factors, the effective range of Bluetooth may change. For troubleshooting purposes, place the sensor next to your phone or tablet.
  • Confirm that you are using a supported device? Currently Humiditrak supports Android 5.0 and up and iOS 8.0 and up. Devices must support Bluetooth 4.0. For a full list of supported devices, see "Supported devices" in "Tips, Tricks, and More".
  • Do you have any other phones or tablets running the Humiditrak App within Bluetooth range of the sensor? If so, turn Bluetooth OFF for these devices. If this fixes the problem, refer to "Using the Humiditrak App with multiple phones" in the "Tips, Tricks and More" section.
  • Did the sensor's battery die? You can find the sensor's battery icon in the upper right hand corner next to the Bluetooth connection icon on the My Instruments page. If so, replace the battery and make sure the sensor's red light blinks 4 times. Refer to "How do I replace my battery" in the "Tips, Tricks and More" section.
  • Is the sensor not listed on the My Instruments page? If so, confirm you are logged into the correct Humiditrak account? Log out of the App, completely close the App and log back in. If the sensor is still missing, next try linking the sensor by pressing the + button in the upper right hand corner. Refer to the "Getting Started" section for more information.
  • Is your sensor's name displaying but not the humidity & temperature icons in the My Instruments list? If so, this means your sensor has been un-linked. Refer to the "Humidity & Temperature icons disappeared" section below.